summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 13:01:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:55 +0100
commit3bad0d842e0ccd7c85da6b67e08ddde720e5fd94 (patch)
tree9afffb3b1131032207eeb0c111c3272fcd147fdb
parent89ad4fc6b3836ebb409c6cebac7e8ac3e5bfdf71 (diff)
gnu: Switch from compositeproto to xorgproto.
* gnu/packages/xorg.scm (compositeproto)[properties]: Mark as superseded by XORGPROTO. (libxcomposite)[propagated-inputs]: Remove COMPOSITEPROTO. (xorg-server)[inputs]: Likewise. * gnu/packages/enlightenment.scm (efl)[inputs]: Likewise.
-rw-r--r--gnu/packages/enlightenment.scm1
-rw-r--r--gnu/packages/xorg.scm10
2 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index ca6b3ddb6e..f3374eaeb1 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -76,7 +76,6 @@
`(("pkg-config" ,pkg-config)))
(inputs
`(("alsa-lib" ,alsa-lib)
- ("compositeproto" ,compositeproto)
("curl" ,curl)
("ghostscript" ,ghostscript)
("giflib" ,giflib)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4e97481f0c..bd84fecc0e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -273,8 +273,8 @@ requests that exceed 262140 bytes in length.")
(description
"Composite Extension contains header files and documentation for
the damage protocol.")
- (license license:x11)))
-
+ (license license:x11)
+ (properties `((superseded . ,xorgproto)))))
(define-public damageproto
(package
@@ -1281,8 +1281,7 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
;; xcomposite.pc refers to all these.
`(("xorgproto" ,xorgproto)
("libxfixes" ,libxfixes)
- ("libx11" ,libx11)
- ("compositeproto" ,compositeproto)))
+ ("libx11" ,libx11)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
@@ -5120,8 +5119,7 @@ over Xlib, including:
("xf86driproto" ,xf86driproto)
("xorgproto" ,xorgproto)))
(inputs
- `(("compositeproto" ,compositeproto)
- ("damageproto" ,damageproto)
+ `(("damageproto" ,damageproto)
("udev" ,eudev)
("dbus" ,dbus)
("dmxproto" ,dmxproto)