summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 23:44:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 23:44:16 +0100
commit3ede1550e8310a8a544c1fb0f7f372c60c00bbe0 (patch)
treeb3abb524b04031dcc452c67aee1643e987b2b295
parent62a4b952c041d5643f1a1ef05450dd8fb59e9bbf (diff)
gnu: cutadapt: Update to 1.16.
* gnu/packages/bioinformatics.scm (cutadapt): Update to 1.16. [source]: Fetch via git. [arguments]: Remove. [native-inputs]: Replace python-nose with python-pytest.
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 8 insertions, 24 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e5e9192993..e13f1b369f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1854,38 +1854,22 @@ file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
(define-public cutadapt
(package
(name "cutadapt")
- (version "1.14")
+ (version "1.16")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/marcelm/cutadapt/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcelm/cutadapt.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "16gbpiwy4m48vq2h5wqar3i8vr6vcj9gcl2qvqim19x6ya9dp8kd"))))
+ "09pr02067jiks19nc0aby4xp70hhgvb554i2y1c04rv1m401w7q8"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; The tests must be run after installation.
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (setenv "PYTHONPATH"
- (string-append
- (getenv "PYTHONPATH")
- ":" (assoc-ref outputs "out")
- "/lib/python"
- (string-take (string-take-right
- (assoc-ref inputs "python") 5) 3)
- "/site-packages"))
- (zero? (system* "nosetests" "-P" "tests")))))))
(inputs
`(("python-xopen" ,python-xopen)))
(native-inputs
`(("python-cython" ,python-cython)
- ("python-nose" ,python-nose)))
+ ("python-pytest" ,python-pytest)))
(home-page "https://cutadapt.readthedocs.io/en/stable/")
(synopsis "Remove adapter sequences from nucleotide sequencing reads")
(description