summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-04 15:20:24 +0200
committerDavid Craven <david@craven.ch>2016-09-06 17:48:59 +0200
commit40b3f52399feeca34e20796c22776f6c462e42c0 (patch)
tree5bf23cbcdf7ff19c6f48f3a80a655a5e0ad06212
parent935644c01ade149f33e1eeea9ed8647f229aa4d6 (diff)
gnu: Add cairo-xcb.
* gnu/packages/gtk.scm (cairo-xcb): New variable.
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 74c4ed36a9..5f55c1ee6f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -149,6 +149,19 @@ affine transformation (scale, rotation, shear, etc.).")
(license license:lgpl2.1) ; or Mozilla Public License 1.1
(home-page "http://cairographics.org/")))
+(define-public cairo-xcb
+ (package
+ (inherit cairo)
+ (name "cairo-xcb")
+ (inputs
+ `(("mesa" ,mesa)
+ ,@(package-inputs cairo)))
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ '("--enable-xlib-xcb" "--enable-gl" "--enable-egl")))
+ (synopsis "2D graphics library (with X11 support)")))
+
(define-public harfbuzz
(package
(name "harfbuzz")