summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 14:21:09 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:18:15 +0300
commit428e4463c3352ede41e8ccbe69b681054a4f90fa (patch)
tree4b62fde889acb99d221cb6fac92b4313e97c77fe
parent3cf17446cf2a67b2de81617dd07b07baf24693e6 (diff)
gnu: Add perl-path-tiny.
* gnu/packages/perl.scm (perl-path-tiny): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6192dae3d8..0f9ecdd9b3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4634,6 +4634,31 @@ up inheritance from those modules at the same time.")
directory specifications in a cross-platform manner.")
(license (package-license perl))))
+(define-public perl-path-tiny
+ (package
+ (name "perl-path-tiny")
+ (version "0.096")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+ "Path-Tiny-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08dmr6ijjg3dp7h9dxix0nmad0fw16c6qzs4qc0hdz500gd64sr2"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require additional test modules to be packaged
+ ;; (native-inputs
+ ;; `(("perl-test-failwarnings" ,perl-test-failwarnings)
+ ;; ("perl-test-mockrandom" ,perl-test-mockrandom)))
+ (inputs
+ `(("perl-unicode-utf8" ,perl-unicode-utf8)))
+ (home-page "http://search.cpan.org/dist/Path-Tiny")
+ (synopsis "File path utility")
+ (description "This module provides a small, fast utility for working
+with file paths.")
+ (license asl2.0)))
+
(define-public perl-perlio-utf8_strict
(package
(name "perl-perlio-utf8-strict")