summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-10 15:32:58 +0100
committerLudovic Courtès <ludo@gnu.org>2019-02-10 23:25:01 +0100
commit44a06c942c36b75c8aab9761891ca64c1f4ac367 (patch)
tree6a40eb2a9e908aa37a68f32c88dcb7b47fa6ba9e
parentb717d0f90eed10c1173ba10b30db82d502b5b9df (diff)
gnu: gnome: Remove '--disable-acceleration-check' flag from 'gnome.desktop'.
With this change the GNOME session is now listed in the log-in screen of GDM. * gnu/packages/gnome.scm (gnome-session)[arguments]: Remove 'disable-hardware-acceleration-check' phase. That phase was apparently no longer needed. Furthermore, GDM expects 'TryExec' to be a file name, not a file name followed by arguments; thus, the option led GDM to discard 'gnome.desktop' with "GdmSession: Command not found: TryExec".
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 850bfcf5e9..db10b0a16b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -4572,16 +4572,6 @@ such as gzip tarballs.")
(out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/gnome-session")
`("PATH" ":" prefix (,(string-append glib "/bin"))))
- #t)))
- (add-after 'install 'disable-hardware-acceleration-check
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Do not abort if hardware acceleration is missing. This allows
- ;; GNOME to run in QEMU and on low-end devices.
- (let ((out (assoc-ref outputs "out")))
- (substitute* (string-append out
- "/share/xsessions/gnome.desktop")
- (("gnome-session")
- "gnome-session --disable-acceleration-check"))
#t))))
#:configure-flags