summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-08-27 14:47:43 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-09-01 15:33:24 -0700
commit450dcd1aff741c4f81cc9508ce33f19e62edefb7 (patch)
tree06fe75e31cc962559264e6876e0734feed9fce3b
parentc7a3926ee438263cfe03bea7e3cdd65c8585ce7a (diff)
gnu: %default-extra-linux-options: Enable kernel options for elogind service.
Fixes: https://issues.guix.gnu.org/43078 These options are already enabled in the kernel configs included in guix, but might be missing from variants using a defconfig from the upstream kernel, such as linux-libre-arm-generic and linux-libre-arm64-generic. * gnu/packages/linux (%default-extra-linux-options): Enable CONFIG_CGROUP_FREEZER, CONFIG_BLK_CGROUP, CONFIG_CGROUP_WRITEBACK, CONFIG_CGROUP_SCHED, CONFIG_CGROUP_PIDS, CONFIG_CGROUP_FREEZER, CONFIG_CGROUP_DEVICE, CONFIG_CGROUP_CPUACCT, CONFIG_CGROUP_PERF, CONFIG_SOCK_CGROUP_DATA, CONFIG_BLK_CGROUP_IOCOST, CONFIG_CGROUP_NET_PRIO, CONFIG_CGROUP_NET_CLASSID, CONFIG_MEMCG, CONFIG_MEMCG_SWAP, CONFIG_MEMCG_KMEM, CONFIG_CPUSETS and CONFIG_PROC_PID_CPUSET.
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d3365e7a4b..d3b3f4de9c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -618,6 +618,26 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("CONFIG_USER_NS" . #t)
("CONFIG_PID_NS" . #t)
("CONFIG_NET_NS" . #t)
+ ;; Various options needed for elogind service:
+ ;; https://issues.guix.gnu.org/43078
+ ("CONFIG_CGROUP_FREEZER" . #t)
+ ("CONFIG_BLK_CGROUP" . #t)
+ ("CONFIG_CGROUP_WRITEBACK" . #t)
+ ("CONFIG_CGROUP_SCHED" . #t)
+ ("CONFIG_CGROUP_PIDS" . #t)
+ ("CONFIG_CGROUP_FREEZER" . #t)
+ ("CONFIG_CGROUP_DEVICE" . #t)
+ ("CONFIG_CGROUP_CPUACCT" . #t)
+ ("CONFIG_CGROUP_PERF" . #t)
+ ("CONFIG_SOCK_CGROUP_DATA" . #t)
+ ("CONFIG_BLK_CGROUP_IOCOST" . #t)
+ ("CONFIG_CGROUP_NET_PRIO" . #t)
+ ("CONFIG_CGROUP_NET_CLASSID" . #t)
+ ("CONFIG_MEMCG" . #t)
+ ("CONFIG_MEMCG_SWAP" . #t)
+ ("CONFIG_MEMCG_KMEM" . #t)
+ ("CONFIG_CPUSETS" . #t)
+ ("CONFIG_PROC_PID_CPUSET" . #t)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)