summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-09-05 14:19:05 +0200
committerJohn Darrington <jmd@gnu.org>2016-09-05 20:47:28 +0200
commit4e835710f1f45ceffb432fa19cc3cfbbdaf0919b (patch)
tree14e12a655bfa2789a4d49e13360eeffe468fb13a
parent823c82929b91727f66e684a612cb6c4f697b6dcb (diff)
gnu: Add git@2.9
* gnu/packages/version-control.scm (git@2.9): New variable. * gnu/packages/version-control.scm (cgit)[inputs]: Replace git with git@2.9
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9ff9801997..d77cca0e10 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -293,6 +293,20 @@ everything from small to very large projects with speed and efficiency.")
(license license:gpl2)
(home-page "http://git-scm.com/")))
+;; Some dependent packages directly access internal interfaces which
+;; have changed in 2.10
+(define-public git@2.9
+ (package
+ (inherit git)
+ (version "2.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kernel.org/software/scm/git/git-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0qzs681a64k3shh5p0rg41l1z16fbk5sj0xga45k34hp1hsp654z"))))))
+
(define-public libgit2
(package
(name "libgit2")
@@ -387,7 +401,7 @@ write native speed custom Git applications in any language with bindings.")
("xmllint" ,libxml2)
("xsltprot" ,libxslt)))
(inputs
- `(("git:src" ,(package-source git))
+ `(("git:src" ,(package-source git@2.9))
("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://git.zx2c4.com/cgit/")