summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-30 23:20:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-03-31 01:05:28 +0300
commit4fbed7494d782f1a1ee027e1a3a2d2e4b12a53ab (patch)
tree5897ff1e517b3d1794c662e973b11b193a9256f8
parent6f9f01fbf616c5f133d8641a9414fd53eefd4d07 (diff)
gnu: rapidjson: Fix building on aarch64.
* gnu/packages/web.scm (rapidjson)[arguments]: Add custom phase for aarch64 to fix -march detection.
-rw-r--r--gnu/packages/web.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1c974370c1..7215dcbed1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
@@ -464,6 +464,17 @@ current version of any major web browser.")
'(substitute* (find-files "." "^CMakeLists\\.txt$")
(("-Werror") "")))))
(build-system cmake-build-system)
+ (arguments
+ `(,@(if (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-aarch-march-detection
+ (lambda _
+ (substitute* (find-files "." "^CMakeLists\\.txt$")
+ (("native") "armv8-a"))
+ #t))))
+ '())))
(home-page "https://github.com/miloyip/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
(description