summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-17 14:20:39 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-18 08:44:48 +0200
commit5ce6c2d91dd4dfaa48b3ece0f6a94a8c90415458 (patch)
tree22242e9f63c51198789c611a214ab3aa1ee4d28a
parent13a5d9f9e32fadb99d0e7415a179050bf337811d (diff)
gnu: gnome-settings-daemon: Record absolute file name of Baobab.
* gnu/packages/gnome.scm (gnome-settings-daemon)[arguments]: Add 'set-baobab-file-name' phase. [inputs]: Add BAOBAB.
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ac8e955e31..15719ef8e7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5127,6 +5127,21 @@ services for numerous locations.")
(string-append "-Dc_link_args=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib/gnome-settings-daemon-3.0"))
+
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-baobab-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Hard-code the file name of Baobab instead of looking
+ ;; it up in $PATH. This ensures users get the "Examine"
+ ;; button in the low disk space notification of GDM even
+ ;; if they don't have GNOME in their main profile.
+ (let ((baobab (assoc-ref inputs "baobab")))
+ (substitute* "plugins/housekeeping/gsd-disk-space.c"
+ (("g_find_program_in_path \\(DISK_SPACE_ANALYZER\\)")
+ (string-append "g_strdup (\"" baobab
+ "/bin/baobab\")")))
+ #t))))
+
;; Color management test can't reach the colord system service.
#:tests? #f))
(native-inputs
@@ -5139,6 +5154,7 @@ services for numerous locations.")
("docbook-xsl" ,docbook-xsl)))
(inputs
`(("alsa-lib" ,alsa-lib)
+ ("baobab" ,baobab)
("colord" ,colord)
("libgudev" ,libgudev)
("upower" ,upower)