summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-29 13:40:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-29 15:47:13 +0200
commit5d01aeba9499ec0439ccfcbcac969899c5c05711 (patch)
tree805e3e61985fed407cfa48a1d5cd9e11bc578ef2
parentd0936fd0c695f435de5b456301769c69ca8de00b (diff)
gnu: Add perl-sql-abstract-classic.
* gnu/packages/databases.scm (perl-sql-abstract-classic): New public variable.
-rw-r--r--gnu/packages/databases.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e2eb0f396d..353cd9842d 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1782,6 +1782,42 @@ structures you provide it, so that you don't have to modify your code every
time your data changes.")
(license license:perl-license)))
+(define-public perl-sql-abstract-classic
+ (package
+ (name "perl-sql-abstract-classic")
+ (version "1.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
+ "SQL-Abstract-Classic-" version ".tar.gz"))
+ (sha256
+ (base32 "0a7g13hs3kdxrjn43sfli09mgsi9d6w0dfw6hlk268av17yisgaf"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-deep" ,perl-test-deep)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-test-warn" ,perl-test-warn)))
+ (propagated-inputs
+ `(("perl-mro-compat" ,perl-mro-compat)
+ ("perl-sql-abstract" ,perl-sql-abstract)))
+ (home-page "https://metacpan.org/release/SQL-Abstract-Classic")
+ (synopsis "Generate SQL from Perl data structures")
+ (description
+ "This module is nearly identical to @code{SQL::Abstract} 1.81, and exists
+to preserve the ability of users to opt into the new way of doing things in
+later versions according to their own schedules.
+
+It is an abstract SQL generation module based on the concepts used by
+@code{DBIx::Abstract}, with several important differences, especially when it
+comes to @code{WHERE} clauses. These concepts were modified to make the SQL
+easier to generate from Perl data structures.
+
+The underlying idea is for this module to do what you mean, based on the data
+structures you provide it. You shouldn't have to modify your code every time
+your data changes, as this module figures it out.")
+ (license license:perl-license)))
+
(define-public perl-sql-splitstatement
(package
(name "perl-sql-splitstatement")