summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 15:05:30 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:31:07 +0300
commit60e8c2ae2c5262e9be4d3c0bdda1b62e86d18dbb (patch)
tree2266dbf2b89144ef768519ab99857adf819bc546
parentb2696a58b3c601abf02ff40cd915c4f6b195743b (diff)
gnu: Add perl-test-manifest.
* gnu/packages/perl.scm (perl-test-manifest): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0f9ecdd9b3..309deb5e42 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5773,6 +5773,29 @@ string comparison functions of Test::More, but which are more suitable when
you test against long strings.")
(license (package-license perl))))
+(define-public perl-test-manifest
+ (package
+ (name "perl-test-manifest")
+ (version "2.02")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/B/BD/BDFOY/"
+ "Test-Manifest-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15ik52l9macrrfizf4y6wj71d4lx7w590h2dfajnkmbxmz786iq6"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "http://search.cpan.org/dist/Test-Manifest")
+ (synopsis "Interact with a t/test_manifest file")
+ (description "@code{Test::Manifest} overrides the default test file order. Instead of
+running all of the t/*.t files in ASCII-betical order, it looks in the t/test_manifest
+file to find out which tests you want to run and the order in which you want to run them.
+It constructs the right value for the build system to do the right thing.")
+ (license (package-license perl))))
+
(define-public perl-test-mockobject
(package
(name "perl-test-mockobject")