summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:14:41 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:45 -0500
commit64f4278624eb863059f4e9ac93bca37cb39b8fae (patch)
treeb62161924f3e0b4103821e6804a50e28e0912efa
parentb37d0c825fa33a25cbd619402e9a31991f31ec50 (diff)
gnu: Add ghc-bitarray.
* gnu/packages/haskell-xyz.scm (ghc-bitarray): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index bd5b599ace..882df583d1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -866,6 +866,27 @@ can use with C code to help write bindings to inline functions or macro
functions.")
(license license:bsd-3)))
+(define-public ghc-bitarray
+ (package
+ (name "ghc-bitarray")
+ (version "0.0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "bitarray/bitarray-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00nqd62cbh42qqqvcl6iv1i9kbv0f0mkiygv4j70wfh5cl86yzxj"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("1" "10fk92v9afjqk43zi621jxl0n8kci0xjj32lz3vqa9xbh67zjz45")))
+ (home-page "https://hackage.haskell.org/package/bitarray")
+ (synopsis "Mutable and immutable bit arrays")
+ (description "The package provides mutable and immutable bit arrays.")
+ (license license:bsd-3)))
+
(define-public ghc-blaze-builder
(package
(name "ghc-blaze-builder")