summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-24 19:20:15 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-25 16:00:17 +0200
commit69e983300f7522af66381a4d41335b8c3d59f8ba (patch)
tree479fe8506fb72f424e824d83be86d9032bf2543c
parente6e031e99b66de92d081802e13c7d74ffba177e9 (diff)
gnu: Add python-simpleeval.
* gnu/packages/python-xyz.scm (python-simpleeval): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7a0307f3ab..6ddd253ed9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9535,6 +9535,27 @@ Features:
@end itemize")
(license license:expat)))
+(define-public python-simpleeval
+ (package
+ (name "python-simpleeval")
+ (version "0.9.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "simpleeval" version))
+ (sha256
+ (base32 "1skvl467kj83rzkhk01i0wm8m5vmh6j5znrfdizn6r18ii45a839"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/danthedeckie/simpleeval")
+ (synopsis "Simple, safe single expression evaluator library")
+ (description
+ "This package provides a quick single file library for easily adding
+evaluatable expressions into python projects. Say you want to allow a user
+to set an alarm volume, which could depend on the time of day, alarm level,
+how many previous alarms had gone off, and if there is music playing at the
+time.")
+ (license license:expat)))
+
(define-public python-nbconvert
(package
(name "python-nbconvert")