summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-04 01:39:57 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-11 23:12:26 +0100
commit6f93b525d3159675478c78541c95452d1b12e5a3 (patch)
tree598e54ee03fa440c121cc6d193cdd2d70f1501a5
parentbfc9c339301ffe6dd15d156894dc27e05f6f081f (diff)
gnu: Add emacs-xml-rpc.
* gnu/packages/emacs-xyz.scm (emacs-xml-rpc): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b7e2167d53..673a490752 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11376,6 +11376,33 @@ Org-mode. It features:
@end itemize\n")
(license license:gpl3+))))
+(define-public emacs-xml-rpc
+ (let ((commit "8f624f8b964e9145acb504e4457c9510e87dd93c")
+ (revision "1"))
+ (package
+ (name "emacs-xml-rpc")
+ (version (git-version "1.6.12" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hexmode/xml-rpc-el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xa54z52rsfl3n0xgmbycj4zazp8ksgdwcq56swzs6wp72zlalmj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/hexmode/xml-rpc-el")
+ (synopsis "XML-RPC client for Emacs")
+ (description "This package provides an XML-RPC client for Emacs capable
+of both synchronous and asynchronous method calls using the @code{url}
+package's async retrieval functionality. @file{xml-rpc.el} represents XML-RPC
+datatypes as Lisp values, automatically converting to and from the XML
+datastructures as needed, both for method parameters and return values, making
+using XML-RPC methods fairly transparent to the Lisp code.")
+ (license license:gpl3+))))
+
(define-public emacs-fish-completion
(package
(name "emacs-fish-completion")