summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-02 09:56:33 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:28 +0200
commit7f3c9116bdd349d49d3f6a148bc59f7f8d64215a (patch)
tree1106f76ad0cb2f1698e8701c872e79302c825a60
parent02c05485fd675c33e10852c3e489663f30f5da29 (diff)
gnu: Add libde265.
* gnu/packages/video.scm (libde265): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/video.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 474838791b..fdd9f082d0 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -216,6 +216,44 @@ applications by providing high-level classes for commonly required tasks.")
(home-page "https://dirk-farin.net/software/libvideogfx/index.html")
(license license:lgpl2.1+)))
+(define-public libde265
+ (package
+ (name "libde265")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/strukturag/libde265.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qisj8ryzbknam3hk81rq70fsd9mcpxm898bqygvbsmbwyvmz3pg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
+ (inputs
+ `(;; XXX: Build fails with libvideogfx.
+ ;; ("libvideogfx" ,libvideogfx)
+ ("qt" ,qtbase)
+ ("sdl" ,sdl)))
+ (synopsis "H.265 video codec implementation")
+ (description "Libde265 is an implementation of the h.265 video codec. It is
+written from scratch and has a plain C API to enable a simple integration into
+other software.")
+ (home-page "https://www.libde265.org/")
+ (license
+ (list
+ ;; Applications.
+ license:expat
+ ;; Library.
+ license:lgpl3+))))
+
(define-public tslib
(package
(name "tslib")