summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2018-06-14 00:56:23 +0200
committerClément Lassieur <clement@lassieur.org>2018-06-14 08:18:06 +0200
commit85d79a79e4b721e24cdfb11a90beef6d566c499a (patch)
treeacce0e2cef3e8cf4d96cf09f8dca505bb9273840
parentb863b50d80f5b8b3ece01c1f7198b57e22e4edf9 (diff)
gnu: Add python-dns-lexicon.
* gnu/packages/python.scm (python-dns-lexicon, python2-dns-lexicon): New variables.
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c09b006096..72e8d9292d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13716,3 +13716,36 @@ Public Suffix List's private domains as well.")
(define-public python2-pynamecheap
(package-with-python2 python-pynamecheap))
+
+(define-public python-dns-lexicon
+ (package
+ (name "python-dns-lexicon")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dns-lexicon" version))
+ (sha256
+ (base32
+ "0jdn3ns71bsybr7njgsqr9xlxsqh7zh6phn4ld0liazqdn2l5f6m"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;requires internet access
+ (propagated-inputs
+ `(("python-future" ,python-future)
+ ("python-pynamecheap" ,python-pynamecheap)
+ ("python-requests" ,python-requests)
+ ("python-tldextract" ,python-tldextract)
+ ("python-urllib3" ,python-urllib3)))
+ (home-page "https://github.com/AnalogJ/lexicon")
+ (synopsis
+ "Manipulate DNS records on various DNS providers")
+ (description
+ "Lexicon provides a way to manipulate DNS records on multiple DNS
+providers in a standardized way. It has a CLI but it can also be used as a
+Python library. It was designed to be used in automation, specifically with
+Let's Encrypt.")
+ (license license:expat)))
+
+(define-public python2-dns-lexicon
+ (package-with-python2 python-dns-lexicon))