summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-09-08 14:03:40 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-13 23:34:23 +0200
commit88915958c0b16c5b6b935d0ad8bf7cc740979640 (patch)
treef5fce30a7b0dd5aa4402bee4265deb41fcd68697
parent227932991f55f3a817d96b8de3193bd89ef6460b (diff)
gnu: glade: Add catalog and module search paths.
* gnu/packages/gnome.scm (glade3)[native-search-paths]: Add GLADE_CATALOG_SEARCH_PATH and GLADE_MODULE_SEARCH_PATH. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9b72e6a7ab..5b08cb18f3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2919,7 +2919,13 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
(description "Glade is a rapid application development (RAD) tool to
enable quick & easy development of user interfaces for the GTK+ toolkit and
the GNOME desktop environment.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (native-search-paths (list (search-path-specification
+ (variable "GLADE_CATALOG_SEARCH_PATH")
+ (files '("share/glade/catalogs")))
+ (search-path-specification
+ (variable "GLADE_MODULE_SEARCH_PATH")
+ (files '("lib/glade/modules")))))))
(define-public libcroco
(package