summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-20 23:41:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-20 23:41:45 +0200
commit915d898f1502e64fd59e7948dbbb6cd708012f8d (patch)
tree743d5d05447fec9026889818ed69537a03f06bb9
parent9015ed66880497ed88854551eca0510a734fe8f4 (diff)
gnu: emacs-hyperbole: Update to 7.0.6.
* gnu/packages/emacs-xyz.scm (emacs-hyperbole): Update to 7.0.6. [source]: Use GNU ELPA URL. Remove some patches. [arguments]: Add phase. * gnu/packages/patches/emacs-hyperbole-do-not-check-dir.patch: Delete file. * gnu/packages/patches/emacs-hyperbole-domainname.patch: Delete file. * gnu/local.mk: Register sole patch.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm37
-rw-r--r--gnu/packages/patches/emacs-hyperbole-do-not-check-dir.patch24
-rw-r--r--gnu/packages/patches/emacs-hyperbole-domainname.patch29
4 files changed, 21 insertions, 70 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index fd3cc88af5..090d0eec36 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -891,6 +891,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
+ %D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0247874c04..b6696d28f2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -253,20 +253,16 @@ using geiser.")
(define-public emacs-hyperbole
(package
(name "emacs-hyperbole")
- (version "7.0.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://ftpmirror.gnu.org/hyperbole/"
- "hyperbole-" version ".tar.gz"))
- (sha256
- (base32
- "0znsjhm0lmzpmkgfni4qzx4l6dp604bmrzp3mwxxax2v96wpwmcx"))
- (patches
- (search-patches
- "emacs-hyperbole-do-not-check-dir.patch"
- "emacs-hyperbole-domainname.patch"
- "emacs-hyperbole-toggle-messaging.patch"))))
+ (version "7.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "hyperbole-" version ".tar"))
+ (sha256
+ (base32 "08gi4v76s53nfmn3s0qcxc3zii0pspjfd6ry7jq1kgm3z34x8hab"))
+ (patches
+ (search-patches "emacs-hyperbole-toggle-messaging.patch"))))
(build-system emacs-build-system)
(arguments
`(#:include '("DEMO"
@@ -277,10 +273,17 @@ using geiser.")
"\\.kotl$")
#:phases
(modify-phases %standard-phases
- (add-before 'install 'make-info
+ ;; Fix build issues about missing "domainname" and "hpmap:dir-user"
+ ;; parent dir.
+ (add-after 'unpack 'fix-build
(lambda _
- (invoke "make" "info"))))))
- (propagated-inputs `(("inetutils" ,inetutils)))
+ (substitute* "hypb.el"
+ (("(/usr)?/bin/domainname") "/bin/hostname"))
+ (substitute* "hyperbole.el"
+ (("\\(hyperb:check-dir-user\\)") ""))
+ #t)))))
+ (propagated-inputs
+ `(("inetutils" ,inetutils))) ;for hostname
(home-page "https://www.gnu.org/software/hyperbole/")
(synopsis "The Everyday Hypertextual Information Manager")
(description
diff --git a/gnu/packages/patches/emacs-hyperbole-do-not-check-dir.patch b/gnu/packages/patches/emacs-hyperbole-do-not-check-dir.patch
deleted file mode 100644
index 66c7a0fb08..0000000000
--- a/gnu/packages/patches/emacs-hyperbole-do-not-check-dir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 3016fbd61e47978be73bbbaf7a8c2709bec42066 Mon Sep 17 00:00:00 2001
-From: Joseph LaFreniere <joseph@lafreniere.xyz>
-Date: Fri, 12 Jul 2019 13:12:40 -0500
-Subject: [PATCH] Do not run hyperb:check-dir-user during initialization
-
----
- hyperbole.el | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/hyperbole.el b/hyperbole.el
-index 872dbaf..6edb2a7 100644
---- a/hyperbole.el
-+++ b/hyperbole.el
-@@ -653,7 +653,6 @@ If FLAG is nil then text is shown, while if FLAG is t the text is hidden."
- (interactive)
- (message "Initializing Hyperbole...")
- (run-hooks 'hyperbole-init-hook)
-- (hyperb:check-dir-user)
- (or (stringp hyperb:user-email)
- (setq hyperb:user-email
- (or (and (boundp 'user-mail-address)
---
-2.22.0
-
diff --git a/gnu/packages/patches/emacs-hyperbole-domainname.patch b/gnu/packages/patches/emacs-hyperbole-domainname.patch
deleted file mode 100644
index cf4b63b54b..0000000000
--- a/gnu/packages/patches/emacs-hyperbole-domainname.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 17c87ac58ce6d475fa1987347fcb868ef7f75e40 Mon Sep 17 00:00:00 2001
-From: Joseph LaFreniere <joseph@lafreniere.xyz>
-Date: Sun, 2 Jun 2019 12:38:27 -0500
-Subject: [PATCH] Replace executable domainname with hostname
-
-Fixes build failure:
-> ice-9/boot-9.scm:752:25: In procedure dispatch-exception:
-> patch-el-files: unable to locate "domainname"
----
- hypb.el | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/hypb.el b/hypb.el
-index 6abc17a..0332946 100644
---- a/hypb.el
-+++ b/hypb.el
-@@ -183,8 +183,7 @@ Global keymap is used unless optional KEYMAP is given."
-
- (defun hypb:domain-name ()
- "Returns current Internet domain name with '@' prepended or nil if none."
-- (let* ((dname-cmd (or (file-exists-p "/usr/bin/domainname")
-- (file-exists-p "/bin/domainname")))
-+ (let* ((dname-cmd (file-exists-p "/bin/hostname"))
- (dname (or (and (boundp 'message-user-fqdn) (stringp message-user-fqdn)
- (string-match "\\." message-user-fqdn)
- message-user-fqdn)
---
-2.21.0
-