summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-25 16:58:19 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-25 17:05:45 +0100
commit9d620590b90e84c714ec0ce723c79e35a59fa5a1 (patch)
tree2b6a35b9763fed37bb918eaf393baafa1942cb28
parentcab6a2535abfe0d5dbf7c3e88d51de62becaf370 (diff)
gnu: Add CTL.
* gnu/packages/graphics.scm (ctl): New variable.
-rw-r--r--gnu/packages/graphics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7cbb86fe6e..1464df0b68 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -119,3 +119,36 @@ exception-handling library.")
use in computer imaging applications. The IlmImf libraries supports storage
of the \"EXR\" file format for storing 16-bit floating-point images.")
(license license:bsd-3)))
+
+(define-public ctl
+ (package
+ (name "ctl")
+ (version "1.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ampas/CTL/archive/ctl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gg04pyvw0m398akn0s1l07g5b1haqv5na1wpi5dii1jjd1w3ynp"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;no 'test' target
+
+ ;; Headers include OpenEXR and IlmBase headers.
+ (propagated-inputs `(("openexr" ,openexr)))
+
+ (home-page "http://ampasctl.sourceforge.net")
+ (synopsis "Color Transformation Language")
+ (description
+ "The Color Transformation Language, or CTL, is a small programming
+language that was designed to serve as a building block for digital color
+management systems. CTL allows users to describe color transforms in a
+concise and unambiguous way by expressing them as programs. In order to apply
+a given transform to an image, the color management system instructs a CTL
+interpreter to load and run the CTL program that describes the transform. The
+original and the transformed image constitute the CTL program's input and
+output.")
+
+ ;; The web site says it's under a BSD-3 license, but the 'LICENSE' file
+ ;; and headers use different wording.
+ (license (license:bsd-style "file://LICENSE"))))