summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:56:12 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commita595c108cd986863a4a9f54b1a2d6b696575581d (patch)
treeb02264037412583f4447ac70b3a1a286dd9784dc
parentda9e3012b59d8013b49a7f578798c016d14c7c9f (diff)
gnu: Add Exporter-Tiny.
* gnu/packages/perl.scm (perl-exporter-tiny): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9c626d118d..589501e44c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -647,6 +647,28 @@ import(), @EXPORT and @EXPORT_OK and not a whole lot else.")
"Exporter-Lite-" version))
(license (package-license perl))))
+(define-public perl-exporter-tiny
+ (package
+ (name "perl-exporter-tiny")
+ (version "0.042")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TO/TOBYINK/"
+ "Exporter-Tiny-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gq2ia8c6n84gdrlc73vab61djs8gs8zf7fqx8cxbg5zxg2j45lg"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Exporter-Tiny")
+ (synopsis "Exporter with the features of Sub::Exporter but only core dependencies")
+ (description "Exporter::Tiny supports many of Sub::Exporter's
+external-facing features including renaming imported functions with the `-as`,
+`-prefix` and `-suffix` options; explicit destinations with the `into` option;
+and alternative installers with the `installler` option. But it's written in
+only about 40% as many lines of code and with zero non-core dependencies.")
+ (license (package-license perl))))
+
(define-public perl-extutils-installpaths
(package
(name "perl-extutils-installpaths")