summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-01 14:38:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-01 14:38:38 +0300
commitaa982985e01efc3b0a477b002d6499ef7fd4d62e (patch)
treec617853468bddc91a174b2b2c553521232f4e2cc
parent4e133f4fe4f501c4f94afbeaf2d5907a0c58fc11 (diff)
gnu: vim-full: Remove unneeded phase.
* gnu/packages/vim.scm (vim-full)[arguments]: Remove custom 'skip-previewpopup phase.
-rw-r--r--gnu/packages/vim.scm7
1 files changed, 0 insertions, 7 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 97f1414d4a..25cf578bb8 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -214,13 +214,6 @@ with the editor vim.")))
,@(substitute-keyword-arguments (package-arguments vim)
((#:phases phases)
`(modify-phases ,phases
- (add-before 'check 'skip-previewpopup
- ;; This test fails when the path to the source is long. See:
- ;; https://github.com/vim/vim/issues/5615
- (lambda _
- (substitute* "src/testdir/test_popupwin.vim"
- ((".*Test_previewpopup.*" line)
- (string-append line "return\n")))))
(add-before 'check 'skip-test87
;; This test fails for unknown reasons after switching
;; to a git checkout.