summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-05 17:41:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-05 18:47:09 +0100
commitab1019f165c627bce0f56343aba9bb166a0f56f4 (patch)
treef960fdb07a55c9d3518c3f1cefe841e71ce74cd8
parentcc2c5c22b5b43824286eea87cb88cd9733d2a738 (diff)
gnu: nyx: Update to 2.1.0.
* gnu/packages/tor.scm (nyx): Update to 2.1.0. [source]: Remove patch. * gnu/packages/patches/nyx-show-header-stats-with-python3.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/nyx-show-header-stats-with-python3.patch70
-rw-r--r--gnu/packages/tor.scm6
3 files changed, 2 insertions, 75 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index eaba6b0bfe..dffc58069d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1073,7 +1073,6 @@ dist_patch_DATA = \
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
%D%/packages/patches/nvi-db4.patch \
%D%/packages/patches/nyacc-binary-literals.patch \
- %D%/packages/patches/nyx-show-header-stats-with-python3.patch \
%D%/packages/patches/oath-toolkit-glibc-compat.patch \
%D%/packages/patches/ocaml-bisect-fix-camlp4-in-another-directory.patch \
%D%/packages/patches/ocaml-bitstring-fix-configure.patch \
diff --git a/gnu/packages/patches/nyx-show-header-stats-with-python3.patch b/gnu/packages/patches/nyx-show-header-stats-with-python3.patch
deleted file mode 100644
index 5b20f180f7..0000000000
--- a/gnu/packages/patches/nyx-show-header-stats-with-python3.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Fri, 22 Jun 2018 02:56:39 +0200
-Subject: nyx: Show header stats.
-
-The following patch was taken verbatim from the upstream repository and
-will be included in the next release.
----
-commit 3494111cc81ad4985e81d0c1ea5e451d8f7a2bcc
-Author: Damian Johnson <atagar@torproject.org>
-Date: Mon Feb 5 20:07:40 2018 -0800
-
- Header stats missing with python3
-
- Ick! took me a while to find this. Python3 changed division from providing ints
- to floats. This in turn caused our header panel to call addstr with float x/y
- coordinates, which made that funciton fail silently. End result is that when
- the header panel showed two columns of stats the right column was missing.
-
- Caught thanks to Stijn.
-
-diff --git a/nyx/panel/header.py b/nyx/panel/header.py
-index 09e3838..fb6f2f7 100644
---- a/nyx/panel/header.py
-+++ b/nyx/panel/header.py
-@@ -155,7 +155,7 @@ class HeaderPanel(nyx.panel.DaemonPanel):
- # space available for content
-
- interface = nyx_interface()
-- left_width = max(subwindow.width / 2, 77) if is_wide else subwindow.width
-+ left_width = max(subwindow.width // 2, 77) if is_wide else subwindow.width
- right_width = subwindow.width - left_width
-
- _draw_platform_section(subwindow, 0, 0, left_width, vals)
-diff --git a/web/changelog/index.html b/web/changelog/index.html
-index 333fa84..196d82b 100644
---- a/web/changelog/index.html
-+++ b/web/changelog/index.html
-@@ -74,6 +74,12 @@
- </ul>
- </li>
-
-+ <li><span class="component">Header</span>
-+ <ul>
-+ <li>Right column of stats missing when using python 3.x</li>
-+ </ul>
-+ </li>
-+
- <li><span class="component">Connections</span>
- <ul>
- <li>Geoip information unavailable for inbound connections</li>
-diff --git a/web/changelog/legacy.html b/web/changelog/legacy.html
-index a380806..02d405f 100644
---- a/web/changelog/legacy.html
-+++ b/web/changelog/legacy.html
-@@ -137,13 +137,13 @@
- </ul>
- </li>
-
-- <li><span class="component">Startup</span>
-+ <li><span class="component">Graph</span>
- <ul>
- <li>Crash when pausing if we showed accounting stats</li>
- </ul>
- </li>
-
-- <li><span class="component">Startup</span>
-+ <li><span class="component">Logging</span>
- <ul>
- <li>Skip reading from malformed tor log files</li>
- <li>Unable to log GUARD events</li>
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 5278bbb43b..db3e1451e9 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -222,16 +222,14 @@ from you.")
(define-public nyx
(package
(name "nyx")
- (version "2.0.4")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
- (patches
- (search-patches "nyx-show-header-stats-with-python3.patch"))
(sha256
(base32
- "0pm7vfcqr02pzqz4b2f6sw5prxxmgqwr1912am42xmy2i53n7nrq"))))
+ "02rrlllz2ci6i6cs3iddyfns7ang9a54jrlygd2jw1f9s6418ll8"))))
(build-system python-build-system)
(inputs
`(("python-stem" ,python-stem)))