summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-21 19:46:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-24 21:29:27 +0100
commitaeccd1bda22326b856ffb8fcd23a799206da0b88 (patch)
tree23155a47dc495266ac1dd208d96c589be927a572
parent7ad608e49d41447e106de4827336c606d4e8d4c8 (diff)
gnu: Add Sub::Install.
* gnu/packages/perl.scm (perl-sub-install): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 699fe751de..cb6fda367a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -274,6 +275,28 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
;; licenses, any version."
(license (list bsd-3 gpl3+))))
+(define-public perl-sub-install
+ (package
+ (name "perl-sub-install")
+ (version "0.928")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RJ/RJBS/Sub-Install-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "03zgk1yh128gciyx3q77zxzxg9kf8yy2gm46gdxqi24mcykngrb1"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Sub-Install")
+ (synopsis "Install subroutines into packages easily")
+ (description
+ "Sub::Install makes it easy to install subroutines into packages without
+the unsightly mess of C<no strict> or typeglobs lying about where just anyone
+can see them.")
+ (license (package-license perl))))
+
(define-public perl-test-deep
(package
(name "perl-test-deep")