summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-25 21:29:52 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-27 20:14:05 +0100
commitb4941e30e3a01a11bf0eac6fd1c68aa33b06aaf8 (patch)
tree2ea156a9dc3e39af0f1b8d0553dfa8343564f753
parente3908ec5fb96a1fbdc144f5585af49668960dfc8 (diff)
gnu: kpackage: Fix build errors in dependent packages.
Fix build errors in dependent packages if PREFIX is different from ECM's PREFIX - which is the case in Guix. See <https://bugs.kde.org/424483> for details. * gnu/packages/patches/plasma-framework-fix-KF5PackageMacros.cmake.patch: New file. * gnu/local.mk (dist_patch_DATA) Add it. * packages/kde-frameworks.scm (package)[source]: Use this patch.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/kde-frameworks.scm3
-rw-r--r--gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch25
3 files changed, 28 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4e425a3e7e..21dbf3da8c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1197,6 +1197,7 @@ dist_patch_DATA = \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
%D%/packages/patches/kpackage-allow-external-paths.patch \
+ %D%/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch \
%D%/packages/patches/kmplayer-aarch64.patch \
%D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index cbcb8ff076..febdb1f4f0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1963,7 +1963,8 @@ covers feedback and persistent events.")
"03rp7p7i8ihz5wg58gjs638jk7xbszknfiy2j3r979snc57g95mv"))
;; Default to: external paths/symlinks can be followed by a
;; package
- (patches (search-patches "kpackage-allow-external-paths.patch"))))
+ (patches (search-patches "kpackage-allow-external-paths.patch"
+ "kpackage-fix-KF5PackageMacros.cmake.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
diff --git a/gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch b/gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch
new file mode 100644
index 0000000000..d677f19a70
--- /dev/null
+++ b/gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch
@@ -0,0 +1,25 @@
+From 668010ebc9fd84d9dc60f90b9a4ebf3c7054977f Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Sun, 25 Oct 2020 20:11:13 +0000
+Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
+
+See <https://bugs.kde.org/424483> for details.
+---
+ KF5PackageMacros.cmake | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/KF5PackageMacros.cmake b/KF5PackageMacros.cmake
+index f4c1d1d..acd3798 100644
+--- a/KF5PackageMacros.cmake
++++ b/KF5PackageMacros.cmake
+@@ -1,6 +1,5 @@
+
+-find_package(ECM 1.6.0 CONFIG REQUIRED)
+-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
++include(KDEInstallDirs)
+
+ set(KPACKAGE_RELATIVE_DATA_INSTALL_DIR "kpackage")
+
+--
+GitLab
+