summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-03-30 17:47:00 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-04-03 21:45:53 +0200
commitb4dcfce51bb3e06710e06881e23493fde3c4763c (patch)
tree129cb76bd12f1d7ab945adc74e4f700b83012eee
parent350a30845c46df55aa0338d0f2fe755275e28fa1 (diff)
gnu: Add cifs-utils.
* gnu/packages/samba.scm (cifs-utils): New variable.
-rw-r--r--gnu/packages/samba.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 3b2a6868d8..8c13222fe3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,8 @@
#:use-module (guix licenses)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
#:use-module (gnu packages databases)
#:use-module (gnu packages tls)
@@ -33,10 +36,54 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages openldap)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages python))
+(define-public cifs-utils
+ (package
+ (name "cifs-utils")
+ (version "6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.samba.org/pub/linux-cifs/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256 (base32
+ "1ayghnkryy1n1zm5dyvyyr7n3807nsm6glfcbbki5c2a8w91dwmj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("keytuils" ,keyutils)
+ ("linux-pam" ,linux-pam)
+ ("libcap-ng" ,libcap-ng)
+ ("mit-krb5" ,mit-krb5)
+ ("samba" ,samba)
+ ("talloc" ,talloc)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The 6.7 tarball is missing ‘install.sh’. Create it.
+ (add-before 'configure 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-i"))))
+ (add-before 'configure 'set-root-sbin
+ (lambda _ ; Don't try to install in "/sbin".
+ (setenv "ROOTSBINDIR"
+ (string-append (assoc-ref %outputs "out") "/sbin"))
+ #t)))))
+ (synopsis "User-space utilities for Linux CIFS (Samba) mounts")
+ (description "@code{cifs-utils} is a set of user-space utilities for
+mounting and managing @dfn{Common Internet File System} (CIFS) shares using
+the Linux kernel CIFS client.")
+ (home-page "https://wiki.samba.org/index.php/LinuxCIFS_utils")
+ ;; cifs-utils is licensed as GPL3 or later, but 3 files contain LGPL code.
+ (license gpl3+)))
+
(define-public iniparser
(package
(name "iniparser")