summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-31 14:33:33 +0200
committerAndreas Enge <andreas@enge.fr>2013-03-31 14:33:33 +0200
commitbd8c5d5b02d33ed5952a7d093298611cadfa5818 (patch)
tree35c24163929383a13d21bf5d9addd6d81171c901
parentbc3073c8e3768f8fcad0b745f8dfd4269a68b7f3 (diff)
gnu: xorg: Add libxp and printproto, not included in X11R7.7.
* gnu/packages/xorg.scm (libxp, printproto): New variables.
-rw-r--r--gnu/packages/xorg.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8376a4230f..d770531f5d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1848,6 +1848,29 @@ tracking.")
(license license:x11)))
+;; The package is missing from X11R7.7.
+(define-public printproto
+ (package
+ (name "printproto")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/proto/printproto-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "06liap8n4s25sgp27d371cc7yg9a08dxcr3pmdjp761vyin3360j"))))
+ (build-system gnu-build-system)
+ (inputs `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.x.org/wiki/")
+ (synopsis "xorg implementation of the X Window System")
+ (description "X.org provides an implementation of the X Window System")
+ (license license:x11)))
+
+
(define-public randrproto
(package
(name "randrproto")
@@ -4215,6 +4238,34 @@ tracking.")
(license license:x11)))
+;; The package is missing from X11R7.7.
+(define-public libxp
+ (package
+ (name "libxp")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/lib/libXp-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1blwrr5zhmwwy87j0svmhv3hc13acyn5j14n5rv0anz81iav2r3y"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("printproto" ,printproto)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://www.x.org/wiki/")
+ (synopsis "xorg implementation of the X Window System")
+ (description "X.org provides an implementation of the X Window System")
+ (license license:x11)))
+
+
(define-public libxrender
(package
(name "libxrender")