summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-20 14:13:06 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-26 17:06:17 +0200
commitc26c062838ac1a4f7cce9f6e4c8f0f8ada043c28 (patch)
tree6d7b6ebf502986f6de8f00fba1627348be56958f
parent35b2001a14b1ac71eb6e8e4226f26177abf8b7c7 (diff)
gnu: Add r-openssl.
* gnu/packages/statistics.scm (r-openssl): New variable.
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 25065c9917..781620ca31 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1345,6 +1345,35 @@ module, Java Server Pages, and Python's psp module.")
collation, and NAMESPACE files.")
(license license:gpl2+)))
+(define-public r-openssl
+ (package
+ (name "r-openssl")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "openssl" version))
+ (sha256
+ (base32
+ "1dbsaciz39zvsmcyxkmpfm5yxzrpw2iv2nb86525wn80q0cyv0cb"))))
+ (build-system r-build-system)
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/jeroenooms/openssl")
+ (synopsis "Toolkit for encryption, signatures and certificates")
+ (description
+ "This package provides R bindings to OpenSSL libssl and libcrypto, plus
+custom SSH pubkey parsers. It supports RSA, DSA and NIST curves P-256, P-384
+and P-521. Cryptographic signatures can either be created and verified
+manually or via x509 certificates. AES block cipher is used in CBC mode for
+symmetric encryption; RSA for asymmetric (public key) encryption. High-level
+envelope functions combine RSA and AES for encrypting arbitrary sized data.
+Other utilities include key generators, hash functions (md5, sha1, sha256,
+etc), base64 encoder, a secure random number generator, and @code{bignum} math
+methods for manually performing crypto calculations on large multibyte
+integers.")
+ (license license:expat)))
+
(define-public r-httr
(package
(name "r-httr")