summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-04-24 00:43:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-04-24 00:47:23 +0200
commitca983a2fc1ee293fb6c1513ee84c316150cb8497 (patch)
tree88121cadff60ff073fc75017ba4ba3aa6d8cc258
parentf6beefafd195e7034a46456d3b4da529c584f055 (diff)
gnu: python2-sh: Fix build.
* gnu/packages/python-xyz.scm (python-sh): Fix build error with Python 2 due to failing tests.
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cbae299ea5..669d465e27 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -476,6 +476,8 @@ concepts.")
(modify-phases %standard-phases
(replace 'check
(lambda _
+ ;; XXX: A Python 2 test fails when HOME=/homeless-shelter.
+ (setenv "HOME" "/tmp")
(invoke "python" "sh.py" "test"))))))
(native-inputs
`(("python-coverage" ,python-coverage)))