summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-09-09 16:47:35 +0200
committerRoel Janssen <roel@gnu.org>2020-09-09 16:47:35 +0200
commitcc61af0b29d0ec43cf104d3d0d2b829e5cc515ef (patch)
treebd2647f52d249797ad2929d7fb2ab7baa7d00c70
parent57add3d0fc5bbd6f73e9b7a137882daf2aed3bc2 (diff)
gnu: Add r-stabs.
* gnu/packages/cran.scm (r-stabs): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a3f3809fe0..9b16920660 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4641,6 +4641,30 @@ automatically.")
supports arbitrary vertex/edge/graph attributes.")
(license license:gpl2+)))
+(define-public r-stabs
+ (package
+ (name "r-stabs")
+ (version "0.6-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "stabs" version))
+ (sha256
+ (base32
+ "17sa0sjxf6h7gx1ga1pxhv17yrz3qisaivbf5cbc3asvshhswqg9"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/hofnerb/stabs")
+ (synopsis "Stability selection with error control")
+ (description
+ "This package provides resampling procedures to assess the stability of
+selected variables with additional finite sample error control for
+high-dimensional variable selection procedures such as Lasso or boosting.
+Both, standard stability selection (Meinshausen & Buhlmann, 2010) and
+complementary pairs stability selection with improved error bounds
+(Shah & Samworth, 2013) are implemented. The package can be combined with
+arbitrary user specified variable selection approaches.")
+ (license license:gpl2)))
+
(define-public r-statnet-common
(package
(name "r-statnet-common")