summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-01 17:02:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-02 17:31:40 +0200
commitd79e8f65b5c0b9726bef4cc89e5fe95bc824b929 (patch)
treef51ec1d279d83e4783e4877363ad6809396ee350
parent2d47cee25b8bb31d22e6803f1cb3e1679641e14a (diff)
gnu: ghc-process: Replace reference to /bin/sh.
* gnu/packages/haskell.scm (ghc-process)[arguments]: Add phases "patch-reference-to-/bin/sh" to replace reference to /bin/sh.
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d79dfd698b..cf17c4f3d8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6918,6 +6918,7 @@ supported. A module of colour names (\"Data.Colour.Names\") is provided.")
files and directories in a portable way.")
(license license:bsd-3)))
+;; Do not use this as an input. It is part of GHC.
(define-public ghc-process
(package
(name "ghc-process")
@@ -6932,6 +6933,14 @@ files and directories in a portable way.")
(base32
"1v1bav5isqxq9fc4lw714x94qbfsjbm2nn12kjp69r1ql8jaaaqw"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-reference-to-/bin/sh
+ (lambda _
+ (substitute* "System/Process/Posix.hs"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(home-page "http://hackage.haskell.org/package/process")
(synopsis "System process libraries")
(description