summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-07 00:21:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-07 02:01:34 +0200
commitd8af4f6ddedb4db527c8c5137fe03684c468a82e (patch)
tree578e632d343a495d2713290346a8350295b4cef5
parent8bad0c0bbb73176ff72a88b47f71d7b07720a483 (diff)
gnu: ntfs-3g: Update to 2017.3.23.
* gnu/packages/linux.scm (ntfs-3g): Update to 2017.3.23. [source]: Remove patch. * gnu/packages/patches/ntfs-3g-CVE-2017-0358.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/linux.scm5
-rw-r--r--gnu/packages/patches/ntfs-3g-CVE-2017-0358.patch43
3 files changed, 2 insertions, 47 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 323866a582..8c00b00208 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -875,7 +875,6 @@ dist_patch_DATA = \
%D%/packages/patches/node-9077.patch \
%D%/packages/patches/nss-increase-test-timeout.patch \
%D%/packages/patches/nss-pkgconfig.patch \
- %D%/packages/patches/ntfs-3g-CVE-2017-0358.patch \
%D%/packages/patches/nvi-assume-preserve-path.patch \
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
%D%/packages/patches/nvi-db4.patch \
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 12a6887925..ed53b79ee9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3262,16 +3262,15 @@ from userspace.")
(define-public ntfs-3g
(package
(name "ntfs-3g")
- (version "2016.2.22")
+ (version "2017.3.23")
(source (origin
(method url-fetch)
(uri (string-append "https://tuxera.com/opensource/"
"ntfs-3g_ntfsprogs-" version ".tgz"))
(sha256
(base32
- "180y5y09h30ryf2vim8j30a2npwz1iv9ly5yjmh3wjdkwh2jrdyp"))
+ "1mb228p80hv97pgk3myyvgp975r9mxq56c6bdn1n24kngcfh4niy"))
(modules '((guix build utils)))
- (patches (search-patches "ntfs-3g-CVE-2017-0358.patch"))
(snippet
;; Install under $prefix.
'(substitute* '("src/Makefile.in" "ntfsprogs/Makefile.in")
diff --git a/gnu/packages/patches/ntfs-3g-CVE-2017-0358.patch b/gnu/packages/patches/ntfs-3g-CVE-2017-0358.patch
deleted file mode 100644
index 83c9dbb3d4..0000000000
--- a/gnu/packages/patches/ntfs-3g-CVE-2017-0358.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Fix CVE-2017-0358:
-http://seclists.org/oss-sec/2017/q1/259
-This patch was copied from the above URL.
-
-diff --git a/src/lowntfs-3g.c b/src/lowntfs-3g.c
-index 0bb38f9..c6d1dad 100644
---- a/src/lowntfs-3g.c
-+++ b/src/lowntfs-3g.c
-@@ -3827,13 +3827,14 @@ static fuse_fstype load_fuse_module(void)
- struct stat st;
- pid_t pid;
- const char *cmd = "/sbin/modprobe";
-+ char *env = (char*)NULL;
- struct timespec req = { 0, 100000000 }; /* 100 msec */
- fuse_fstype fstype;
-
- if (!stat(cmd, &st) && !geteuid()) {
- pid = fork();
- if (!pid) {
-- execl(cmd, cmd, "fuse", NULL);
-+ execle(cmd, cmd, "fuse", NULL, &env);
- _exit(1);
- } else if (pid != -1)
- waitpid(pid, NULL, 0);
-diff -ur ntfs-3g.old/src/ntfs-3g.c ntfs-3g/src/ntfs-3g.c
---- ntfs-3g.old/src/ntfs-3g.c 2017-02-09 15:01:04.074331542 -0500
-+++ ntfs-3g/src/ntfs-3g.c 2017-02-09 15:06:26.077252571 -0500
-@@ -3612,13 +3612,14 @@
- struct stat st;
- pid_t pid;
- const char *cmd = "/sbin/modprobe";
-+ char *env = (char*)NULL;
- struct timespec req = { 0, 100000000 }; /* 100 msec */
- fuse_fstype fstype;
-
- if (!stat(cmd, &st) && !geteuid()) {
- pid = fork();
- if (!pid) {
-- execl(cmd, cmd, "fuse", NULL);
-+ execle(cmd, cmd, "fuse", NULL, &env);
- _exit(1);
- } else if (pid != -1)
- waitpid(pid, NULL, 0);