summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:53:23 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 17:04:24 +0200
commitdaa9e89d564facecdde2ac68e3d4d6bb751ed7f1 (patch)
tree78d08fd4943577cdaa44f0e2f38fbb70c0b66de9
parent49fd0392173f79c19dd85130d22fbec60a9bfe72 (diff)
gnu: Add emacs-helm-flycheck.
* gnu/packages/emacs.scm (emacs-helm-flycheck): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f4d9bebdd3..b7288161dc 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10995,3 +10995,29 @@ from @code{emms-source-file-default-directory}.")
switch between the various windows of one or several specific applications.
See @code{helm-exwm-switch-browser} for an example.")
(license license:gpl3+))))
+
+(define-public emacs-helm-flycheck
+ (let ((commit "3cf7d3bb194acacc6395f88360588013d92675d6"))
+ (package
+ (name "emacs-helm-flycheck")
+ (version (git-version "0.4" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yasuyk/helm-flycheck")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1a2yfxhz04klwhcandqvfzysxp6b7bxyxx1xk1x3kds5hif5fkl4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-flycheck" ,flycheck)
+ ("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/yasuyk/helm-flycheck")
+ (synopsis "Show Flycheck errors with Helm")
+ (description
+ "This integrates Flycheck with Helm.")
+ (license license:gpl3+))))