summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Baptiste Note <jean-baptiste.note@m4x.org>2020-10-28 11:22:39 -0400
committerLudovic Courtès <ludo@gnu.org>2020-11-02 14:59:35 +0100
commitdcd8a50350aeca37a8b55b729a1951940f72d7d2 (patch)
tree5b75a13b6c1b671e259ad18732e4ab8d362f7bab
parent76ea70bd70aeb76570445c11cea2f98139192b54 (diff)
gnu: squid: Fix build reproducibility issue.
* gnu/packages/networking.scm (squid): Add --disable-arch-native configure flag. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/networking.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index dafe928bab..734f5611ca 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1559,7 +1559,11 @@ TCP connection, TLS handshake and so on) in the terminal.")
(base32 "1q1ywpic6s7dfjj3cwzcfgscc4zq0aih462gyas7j1z683ss14b8"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags
+ ;; disable -march=native in build for reproducibility; see
+ ;; https://wiki.squid-cache.org/KnowledgeBase/IllegalInstructionError
+ (list "--disable-arch-native")
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'fix-true-path
(lambda* (#:key inputs #:allow-other-keys)