summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-03 18:47:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-05 16:37:50 +0100
commite1e803881c772398712f10cc450031e437df18b6 (patch)
treea27b82db17ed5227e7b8de122ba4fc18b9820b45
parent092ab12fc3e0fa4465b4a43748837cc75acdfdfb (diff)
gnu: ghc-exceptions: Run tests.
* gnu/packages/haskell.scm (ghc-exceptions)[arguments]: Delete to run tests. [native-inputs]: Add ghc-test-framework and ghc-test-framework-quickcheck2.
-rw-r--r--gnu/packages/haskell.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c5bc8d19a9..f255afb6e9 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2658,7 +2658,9 @@ online}.")
(base32
"1gl7xzffsqmigam6zg0jsglncgzxqafld2p6kb7ccp9xirzdjsjd"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: Missing test-framework package.
+ (native-inputs
+ `(("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
(inputs
`(("ghc-stm" ,ghc-stm)
("ghc-mtl" ,ghc-mtl)