summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Brown <ecbrown@ericcbrown.com>2020-05-28 23:12:08 -0400
committerLeo Famulari <leo@famulari.name>2020-05-28 23:42:49 -0400
commitfa2811465b9ae5de278cfc3615c478a30eae49db (patch)
treeac579845b47f1916b27c09f2512124dc5086bf92
parentd7aef3ab59837b9ed8abbe199debf8ed687f6782 (diff)
gnu: Add r-brms.
* gnu/packages/cran.scm (r-brms): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fff71790b6..fb450eb25d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21726,3 +21726,55 @@ of R without the need of linking to R code. Rserve supports remote
connection, user authentication and file transfer. A simple R client is
included in this package as well.")
(license license:gpl2)))
+
+(define-public r-brms
+ (package
+ (name "r-brms")
+ (version "2.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "brms" version))
+ (sha256
+ (base32
+ "1699lwkklfhjz7fddawlig552g2zvrc34mqwrzqjgl35r9fm08gs"))))
+ (properties `((upstream-name . "brms")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abind" ,r-abind)
+ ("r-backports" ,r-backports)
+ ("r-bayesplot" ,r-bayesplot)
+ ("r-bridgesampling" ,r-bridgesampling)
+ ("r-coda" ,r-coda)
+ ("r-future" ,r-future)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-glue" ,r-glue)
+ ("r-loo" ,r-loo)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-mgcv" ,r-mgcv)
+ ("r-nleqslv" ,r-nleqslv)
+ ("r-nlme" ,r-nlme)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rstan" ,r-rstan)
+ ("r-rstantools" ,r-rstantools)
+ ("r-shinystan" ,r-shinystan)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/paul-buerkner/brms")
+ (synopsis
+ "Bayesian Regression Models using 'Stan'")
+ (description
+ "Fit Bayesian generalized (non-)linear multivariate multilevel models
+using 'Stan' for full Bayesian inference. A wide range of distributions and
+link functions are supported, allowing users to fit -- among others -- linear,
+robust linear, count data, survival, response times, ordinal, zero-inflated,
+hurdle, and even self-defined mixture models all in a multilevel context.
+Further modeling options include non-linear and smooth terms, auto-correlation
+structures, censored data, meta-analytic standard errors, and quite a few
+more. In addition, all parameters of the response distribution can be
+predicted in order to perform distributional regression. Prior specifications
+are flexible and explicitly encourage users to apply prior distributions that
+actually reflect their beliefs. Model fit can easily be assessed and compared
+with posterior predictive checks and leave-one-out cross-validation.")
+ (license license:gpl2)))