summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-14 04:01:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-14 04:01:21 +0200
commitff76a1e9cad607cb0b91f1e46c65aa1c87b131f6 (patch)
tree37268ad68f77beb1685f360a637d98aae3b8ae1c
parent2b78360138a7043e868875137c40266bd1c75dce (diff)
gnu: python-gnupg: Update to 0.4.3.
* gnu/packages/gnupg.scm (python-gnupg): Update to 0.4.3. [arguments]: Remove obsolete substitution.
-rw-r--r--gnu/packages/gnupg.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 42b54c1ea0..ff2efb759e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -508,14 +508,14 @@ decrypt messages using the OpenPGP format by making use of GPGME.")
(define-public python-gnupg
(package
(name "python-gnupg")
- (version "0.3.8")
+ (version "0.4.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-gnupg" version))
(sha256
(base32
- "0nkbs9c8f30lra7ca39kg91x8cyxn0jb61vih4qky839gpbwwwiq"))))
+ "03dc8whhvk7ccspbk8vzfhkxli8cd9zfbss5p597g4jldgy8s59d"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -523,8 +523,6 @@ decrypt messages using the OpenPGP format by making use of GPGME.")
(replace 'check
(lambda _
(substitute* "test_gnupg.py"
- ;; Exported keys don't have a version line!
- (("del k1\\[1\\]") "#")
;; Unsure why this test fails.
(("'test_search_keys'") "True")
(("def test_search_keys") "def disabled__search_keys"))