summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-04 02:45:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-04 06:36:17 +0100
commit2bde4a1d12d6ec1afefa642a77b1c77c31485510 (patch)
tree2bcf10eae154f97b3d4596cabcc63b3314e124d2
parentc90aade8afaf87e7ff2f98a6ec5525276b7e4f66 (diff)
gnu: zfs: Update to 0.8.5.
* gnu/packages/file-systems.scm (zfs): Update to 0.8.5. [arguments]: Update. Don't install initramfs-tools hooks.
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 6ceaad4fd1..c29f429c60 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -698,7 +698,7 @@ APFS.")
(define-public zfs
(package
(name "zfs")
- (version "0.8.2")
+ (version "0.8.5")
(outputs '("out" "module" "src"))
(source
(origin
@@ -707,8 +707,7 @@ APFS.")
"/download/zfs-" version
"/zfs-" version ".tar.gz"))
(sha256
- (base32
- "1f7aig15q3z832pr2n48j3clafic2yk1vvqlh28vpklfghjqwq27"))))
+ (base32 "0gfdnynmsxbhi97q73smrgmcw1k8zmlr1hgljfn38sk0kimivd6v"))))
(build-system linux-module-build-system)
(arguments
`(;; The ZFS kernel module should not be downloaded since the license
@@ -722,8 +721,7 @@ APFS.")
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "configure"
- (("-/bin/sh") (string-append "-" (which "sh")))
- ((" /bin/sh") (string-append " " (which "sh"))))
+ (("-/bin/sh") (string-append "-" (which "sh"))))
(invoke "./configure"
"--with-config=all"
(string-append "--prefix=" out)
@@ -739,6 +737,9 @@ APFS.")
(src (assoc-ref outputs "src"))
(util-linux (assoc-ref inputs "util-linux"))
(nfs-utils (assoc-ref inputs "nfs-utils")))
+ (substitute* "contrib/Makefile.in"
+ ;; This is not configurable nor is its hard-coded /usr prefix.
+ ((" initramfs") ""))
(substitute* "module/zfs/zfs_ctldir.c"
(("/usr/bin/env\", \"umount")
(string-append util-linux "/bin/umount\", \"-n"))
@@ -782,7 +783,6 @@ APFS.")
"INSTALL_MOD_STRIP=1")
(install-file "contrib/bash_completion.d/zfs"
(string-append out "/share/bash-completion/completions"))
- (symlink "../share/pkgconfig/" (string-append out "/lib/pkgconfig"))
#t))))))
(native-inputs
`(("attr" ,attr)