summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-04 12:40:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-04 15:30:28 +0200
commite98fd9fe3fa11d57040735214c3af5a0eee5ed11 (patch)
treee11ea7fef90e0f25f3933cf45dbd22501ab5d791
parentb4578379e57b59d90c6056b7c241109062c0c2a8 (diff)
gnu: java-woodstox-core: Don't use unstable tarball.
* gnu/packages/java.scm (java-woodstox-core)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/java.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7000d49de0..b1b60a3dac 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9668,12 +9668,14 @@ interface and high-performance Typed Access API.")
(name "java-woodstox-core")
(version "5.0.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/FasterXML/woodstox/archive/"
- "woodstox-core-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FasterXML/woodstox")
+ (commit (string-append "woodstox-core-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1i7pdgb8jbw6gdy5kmm0l6rz109n2ns92pqalpyp24vb8vlvdfd4"))))
+ "0bfylk24a967hwxprxqbg6cdvm6n4ldcarp54yg980viwvjiglyp"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "woodstox.jar"