summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-04 14:05:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:57:31 +0300
commit0d601e3860eba0a12ba5150153e41facc10fed34 (patch)
tree282d34f5523f6c155f1c148a637975c9a1d8aa41
parenta60f26b24d3ca400488d45faca0444e0db450f32 (diff)
gnu: Add rust-stdweb-internal-runtime.
* gnu/packages/crates-io.scm (rust-stdweb-internal-runtime): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1a9df7f50a..21c150c008 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -700,6 +700,26 @@ spinning. They may contain data, are usable without @code{std},and static
initializers are available.")
(license license:expat)))
+(define-public rust-stdweb-internal-runtime
+ (package
+ (name "rust-stdweb-internal-runtime")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "stdweb-internal-runtime" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nhpyra7glbwcpakhpj5a3d7h7kx1ynif473nzshmk226m91f8ym"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/koute/stdweb")
+ (synopsis "Internal runtime for the @code{stdweb} crate")
+ (description "This crate provides internal runtime for the @code{stdweb}
+crate.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-unicode-xid
(package
(name "rust-unicode-xid")