summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:12:03 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:11 +0200
commit5150c6e53d804ea6cda4c8b132674ab9519281fa (patch)
tree72e067d740352e94430f96a3cab570d40ce129a2
parent3b60b5fa89eff88991f439577233eb20e4e22cbc (diff)
gnu: Add emacs-helm-dash.
* gnu/packages/emacs-xyz.scm (emacs-helm-dash): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7e339a801e..48f3edc674 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14932,6 +14932,32 @@ previewed by scrolling up and down within a @code{dired} buffer.")
and searching through @code{Ctags} files.")
(license license:gpl3+)))
+(define-public emacs-helm-dash
+ (let ((commit "192b862185df661439a06de644791171e899348a")
+ (version "1.3.0")
+ (revision "18"))
+ (package
+ (name "emacs-helm-dash")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/areina/helm-dash")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06am5vnr4hsxkvh2b8q8kb80y5x1h3qyv7gwggswwhfa7w2vba3w"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/areina/helm-dash")
+ (synopsis "Offline documentation browser for APIs using Dash docsets")
+ (description "This package uses Helm to install and navigate through
+Dash docsets.")
+ (license license:gpl3+))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.