summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-08 16:55:07 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-08 16:58:30 +0100
commitbc47583412745e38d994a4ba71cda6564aed3a35 (patch)
tree2184af6f30243c6871848785c16da4ab85d56645
parent4e9ded6d276bf488593f53a84b6e50771abac13f (diff)
gnu: cross-base: Move glibc Hurd patches to 'inputs'.
Fixes "guix build --target=i586-pc-gnu bootstrap-tarballs". * gnu/packages/cross-base.scm (cross-libc): Move Hurd patches from 'native-inputs' to 'inputs'.
-rw-r--r--gnu/packages/cross-base.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index b35a3cb40b..c1e5f2eb79 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -539,19 +539,20 @@ and the cross tool chain."
;; FIXME: 'static-bash' should really be an input, not a native input, but
;; to do that will require building an intermediate cross libc.
- (inputs '())
+ (inputs (if (hurd-triplet? target)
+ `(;; TODO: move to glibc in the next rebuild cycle
+ ("hurd-mach-print.patch"
+ ,(search-patch "glibc-hurd-mach-print.patch"))
+ ("hurd-gettyent.patch"
+ ,(search-patch "glibc-hurd-gettyent.patch")))
+ '()))
(native-inputs `(("cross-gcc" ,xgcc)
("cross-binutils" ,xbinutils)
,@(if (hurd-triplet? target)
`(("cross-mig"
,@(assoc-ref (package-native-inputs xheaders)
- "cross-mig"))
- ;; TODO: move to glibc in the next rebuild cycle
- ("hurd-mach-print.patch"
- ,@(search-patches "glibc-hurd-mach-print.patch"))
- ("hurd-gettyent.patch"
- ,@(search-patches "glibc-hurd-gettyent.patch")))
+ "cross-mig")))
'())
,@(package-inputs libc) ;FIXME: static-bash
,@(package-native-inputs libc))))))