summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 12:50:17 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 09:45:27 +0800
commitd213718208fa767386a01ea66a86e391edf74331 (patch)
tree26d3c068cf8ef398a3bf8cfd1992b40719b151e1
parent977b0db4c0e4c5672600e3c14587048a7a6a15fd (diff)
gnu: Add rfc2388.
* gnu/packages/lisp.scm (sbcl-rfc2388, cl-rfc2388): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index c43a368970..b8fe98d498 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3873,6 +3873,32 @@ backtrace portably.")
(define-public cl-trivial-backtrace
(sbcl-package->cl-source-package sbcl-trivial-backtrace))
+(define-public sbcl-rfc2388
+ (let ((commit "591bcf7e77f2c222c43953a80f8c297751dc0c4e")
+ (revision "1"))
+ (package
+ (name "sbcl-rfc2388")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jdz/rfc2388.git")
+ (commit commit)))
+ (sha256
+ (base32 "0phh5n3clhl9ji8jaxrajidn22d3f0aq87mlbfkkxlnx2pnw694k"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/jdz/rfc2388/")
+ (synopsis "An implementation of RFC 2388 in Common Lisp")
+ (description
+ "This package contains an implementation of RFC 2388, which is used to
+process form data posted with HTTP POST method using enctype
+\"multipart/form-data\".")
+ (license license:bsd-2))))
+
+(define-public cl-rfc2388
+ (sbcl-package->cl-source-package sbcl-rfc2388))
+
(define-public sbcl-cl+ssl
(let ((commit "b81c1135cf5700e870ce2573d5035d249e491788")
(revision "1"))