summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-14 22:26:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:34 -0400
commitf421785bd7bf44da6080b1d5df9311a5486c49a7 (patch)
tree866329a0f445edc7ff8a1456ea7becd210a5f816
parentdb9f951b837a95558e98564fdeed1cc2fd37d39b (diff)
gnu: Add ruby-text-hyphen.
* gnu/packages/ruby.scm (ruby-text-hyphen): New variable.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 530e5a14f7..21b1abade4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1645,6 +1645,31 @@ integer math and a highly optimized saving routine.
(home-page "https://github.com/wvanbergen/chunky_png/wiki")
(license license:expat))))
+(define-public ruby-text-hyphen
+ (package
+ (name "ruby-text-hyphen")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "text-hyphen" version))
+ (sha256
+ (base32
+ "1gj4awvs9ryf960m0iawg43jyjmfwcqgfwrbcfp890a57b9ag7q1"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (synopsis "Ruby library to hyphenate words in various languages")
+ (description "Text::Hyphen is a Ruby library to hyphenate words in various
+languages using Ruby-fied versions of TeX hyphenation patterns. It will
+properly hyphenate various words according to the rules of the language the
+word is written in. The algorithm is based on that of the TeX typesetting
+system by Donald E. Knuth.")
+ (home-page "https://github.com/halostatue/text-hyphen")
+ ;; The whole is licensed under the Expat license, but parts use various
+ ;; versions of the LaTeX Project Public License.
+ (license license:expat)))
+
(define-public ruby-ast
(package
(name "ruby-ast")