summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-02-09 17:40:39 -0500
committer宋文武 <iyzsong@member.fsf.org>2021-02-11 16:23:47 +0800
commit1755498ca7121abaa8a71de82bd11fbb8b0e912e (patch)
tree8b343e536e90994dc6a54ce5cbf7c34bb4b84e3b
parentfb2107cd4a54e13789295cb98fe69f20cc42b66b (diff)
gnu: gajim-openpgp: Update to 1.3.9.
* gnu/packages/messaging.scm (gajim-openpgp): Update to 1.3.9. [propagated-inputs]: Add python-gpg. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/messaging.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 641ddb6ca1..1878c71c7d 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1122,7 +1122,7 @@ multi-client end-to-end encryption.")
(define-public gajim-openpgp
(package
(name "gajim-openpgp")
- (version "1.2.14")
+ (version "1.3.9")
(source
(origin
(method url-fetch/zipbomb)
@@ -1131,7 +1131,7 @@ multi-client end-to-end encryption.")
"https://ftp.gajim.org/plugins_releases/openpgp_"
version ".zip"))
(sha256
- (base32 "0wdjpf1i4pvl4ha4plfpywwi9aw5n2mhrpv8mmbidpawxqfbd94b"))))
+ (base32 "0fzvvrap1hmj4rbrcjs6cs5c9l9c0795bgw9vxxxk915n6j91m23"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -1146,7 +1146,8 @@ multi-client end-to-end encryption.")
#t))))
(propagated-inputs
`(("python-cryptography" ,python-cryptography)
- ("python-gnupg" ,python-gnupg)))
+ ("python-gnupg" ,python-gnupg)
+ ("python-gpg" ,python-gpg)))
(synopsis "Gajim OpenPGP plugin")
(description "Gajim-OpenPGP is a plugin that adds support for the OpenPGP
Encryption to Gajim.")