summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-06 21:22:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-06 21:22:55 +0200
commit4e2a7cc12fe578f2631ee2f4f40e402e9eaa58f7 (patch)
tree2afb89a1638dcb4afcced07c60c9d43979fd0495
parent3d3185b54448cb44fffc1badc8c1cf51bb76585d (diff)
gnu: python-curtsies: Update to 0.3.4.
* gnu/packages/terminals.scm (python-curtsies): Update to 0.3.4. [home-page]: Update to new home-page. (python2-curtsies): Remove variable.
-rw-r--r--gnu/packages/terminals.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index b313c806cb..74e1937bbc 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Mckinley Olsen <mck.olsen@gmail.com>
;;; Copyright © 2016, 2017, 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -932,14 +932,14 @@ than a terminal.")
(define-public python-curtsies
(package
(name "python-curtsies")
- (version "0.2.11")
+ (version "0.3.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "curtsies" version))
(sha256
(base32
- "1vljmw3sy6lrqahhpyg4gk13mzcx3mwhvg8s41698ms3cpgkjipc"))))
+ "019bpf5wmng4f6ic2ykg893ypfihpfvzi6dhblcagfwbincl79ac"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -954,7 +954,7 @@ than a terminal.")
`(("python-mock" ,python-mock)
("python-pyte" ,python-pyte)
("python-nose" ,python-nose)))
- (home-page "https://github.com/thomasballinger/curtsies")
+ (home-page "https://github.com/bpython/curtsies")
(synopsis "Library for curses-like terminal interaction with colored
strings")
(description "Curtsies is a Python library for interacting with the
@@ -962,9 +962,6 @@ terminal. It features string-like objects which carry formatting information,
per-line fullscreen terminal rendering, and keyboard input event reporting.")
(license license:expat)))
-(define-public python2-curtsies
- (package-with-python2 python-curtsies))
-
(define-public tmate
(package
(name "tmate")