summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-04 15:17:45 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-05 12:08:28 +0200
commitaf66a9510fdbe9a7cb3ad2a1acdf190553727704 (patch)
tree82bebefca029f0e14744afd30d18b96a2b90e27d
parentc47f3fc13562d82edfd2d47342574154c452843a (diff)
gnu: guix: Phases refer to #:system, #:target, and #:native-inputs.
* gnu/packages/package-management.scm (guix)[arguments]: In 'copy-bootstrap-guile' and 'wrap-program' phases, refer to #:system, #:native-inputs, and #:target instead of unquoting (%current-system) and (%current-target-system).
-rw-r--r--gnu/packages/package-management.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 56b436c6f8..3f72d4fac9 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -261,11 +261,9 @@ $(prefix)/etc/openrc\n")))
(intern (assoc-ref inputs "boot-guile") #f)
;; On x86_64 some tests need the i686 Guile.
- ,@(if (and (not (%current-target-system))
- (string=? (%current-system)
- "x86_64-linux"))
- '((intern (assoc-ref inputs "boot-guile/i686") #f))
- '())
+ (when (and (not target)
+ (string=? system "x86_64-linux"))
+ (intern (assoc-ref inputs "boot-guile/i686") #f))
;; Copy the bootstrap executables.
(for-each (lambda (input)
@@ -299,9 +297,8 @@ $(prefix)/etc/openrc\n")))
;; Make sure the 'guix' command finds GnuTLS,
;; Guile-JSON, and Guile-Git automatically.
(let* ((out (assoc-ref outputs "out"))
- (guile ,@(if (%current-target-system)
- '((assoc-ref native-inputs "guile"))
- '((assoc-ref inputs "guile"))))
+ (guile (assoc-ref (or native-inputs inputs)
+ "guile"))
(avahi (assoc-ref inputs "guile-avahi"))
(gcrypt (assoc-ref inputs "guile-gcrypt"))
(guile-lib (assoc-ref inputs "guile-lib"))
@@ -318,9 +315,7 @@ $(prefix)/etc/openrc\n")))
(locales (assoc-ref inputs "glibc-utf8-locales"))
(deps (list gcrypt json sqlite gnutls git
bs ssh zlib lzlib zstd guile-lib))
- (deps* ,@(if (%current-target-system)
- '(deps)
- '((cons avahi deps))))
+ (deps* (if avahi (cons avahi deps) deps))
(effective
(read-line
(open-pipe* OPEN_READ