summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-05 15:18:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-05 16:31:06 -0400
commitb1b41a23f4e48e35bafe282029190bba32cb7218 (patch)
tree8456b8560d73a7529e4ac3eaed0aa8f91d92ce78
parent6e71e719522adec83b49a1533af8b5838479c8fb (diff)
build: Do not compress the (already compressed) VM qcow2 images.
The qcow2 format supports compression, and the qcow2 type supported by 'guix system image' produces compressed qcow2 images. * Makefile.am (release): Do not re-compress the qcow2 VM images with xz. * doc/guix.texi (Running Guix in a VM): Adjust VM image URL.
-rw-r--r--Makefile.am4
-rw-r--r--doc/guix.texi2
2 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c6028c586a..d06e1779ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -900,9 +900,7 @@ release: dist-with-updated-version all
echo "failed to produced Guix VM image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz.tmp" ; \
- mv "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz.tmp" \
- "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz" ; \
+ cp "$$image" "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2"; \
done
@echo
@echo "Congratulations! All the release files are now in $(releasedir)."
diff --git a/doc/guix.texi b/doc/guix.texi
index 7f54ddfb3c..9beef61c94 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -33491,7 +33491,7 @@ Whether or not the droplet should be created with IPv6 networking.
@cindex virtual machine
To run Guix in a virtual machine (VM), one can use the pre-built Guix VM image
distributed at
-@url{@value{BASE-URL}/guix-system-vm-image-@value{VERSION}.x86_64-linux.qcow2.xz}.
+@url{@value{BASE-URL}/guix-system-vm-image-@value{VERSION}.x86_64-linux.qcow2}.
This image is a compressed image in QCOW format. You will first need to
decompress with @command{xz -d}, and then you can pass it to an emulator such
as QEMU (see below for details).