summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-08 18:57:08 +0200
committerMarius Bakke <marius@gnu.org>2020-06-08 19:01:41 +0200
commit087e760e293f6fe9c7d608d732576c4b559f1e2f (patch)
tree519c819d3561521c75e69d67cfb0d1a87e9feeaa
parent183858d938d60b0ba7ea0ca183f6da153a74864e (diff)
gnu: Add python-mechanize.
* gnu/packages/python-xyz.scm (python2-mechanize): Rename to ... (python-mechanize): ... this. Update to 0.4.5. [arguments]: Remove. [propagated-inputs]: Add PYTHON-HTML5LIB. [home-page]: Update to current. [license]: Set to LICENSE:BSD-3. (python2-mechanize): Define in terms of PACKAGE-WITH-PYTHON2.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abf25c6107..abf12ec4e0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1669,38 +1669,30 @@ human-friendly syntax.")
(define-public python2-schedule
(package-with-python2 python-schedule))
-(define-public python2-mechanize
+(define-public python-mechanize
(package
- (name "python2-mechanize")
- (version "0.2.5")
+ (name "python-mechanize")
+ (version "0.4.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mechanize" version))
(sha256
(base32
- "0rj7r166i1dyrq0ihm5rijfmvhs8a04im28lv05c0c3v206v4rrf"))))
+ "1z9kqcwb8gfq2l6i42z624kxpd8692a0c8gw2x5bbm7n848w2mb3"))))
(build-system python-build-system)
- (arguments
- `(#:python ,python-2 ; apparently incompatible with Python 3
- #:tests? #f))
- ;; test fails with message
- ;; AttributeError: 'module' object has no attribute 'test_pullparser'
- ;; (python-3.3.2) or
- ;; AttributeError: 'module' object has no attribute 'test_urllib2_localnet'
- ;; (python-2.7.5).
- ;; The source code is from March 2011 and probably not up-to-date
- ;; with respect to python unit tests.
- (home-page "http://wwwsearch.sourceforge.net/mechanize/")
+ (propagated-inputs
+ `(("python-html5lib" ,python-html5lib)))
+ (home-page "https://github.com/python-mechanize/mechanize")
(synopsis
"Stateful programmatic web browsing in Python")
(description
"Mechanize implements stateful programmatic web browsing in Python,
after Andy Lester’s Perl module WWW::Mechanize.")
- (license (license:non-copyleft
- "file://COPYING"
- "See COPYING in the distribution."))))
+ (license license:bsd-3)))
+(define-public python2-mechanize
+ (package-with-python2 python-mechanize))
(define-public python-simplejson
(package