summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:10:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:05 +0300
commit0e4448d138de6099952e0ecb632beb680b48be0c (patch)
tree1fae0a09b2817ecf80bc5b26b5c5cf791527b8fd
parent913096271fc81f622327730f7ae55ebfff26a836 (diff)
gnu: Add rust-permutohedron.
* gnu/packages/crates-io.scm (rust-permutohedron): New variable.
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3bdf1ce0c1..e793bd77eb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -860,6 +860,28 @@ the @code{take_while} predicate returned false after dropping the @code{by_ref}.
(license (list license:asl2.0
license:expat))))
+(define-public rust-permutohedron
+ (package
+ (name "rust-permutohedron")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "permutohedron" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0b1pzh48j86v46wxngch6k1kx9cdw3jr3lwa86gd6jd4bmxzz1xn"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/bluss/permutohedron")
+ (synopsis "Generate permutations of sequences")
+ (description
+ "Generate permutations of sequences. Either lexicographical order
+permutations, or a minimal swaps permutation sequence implemented using Heap's
+algorithm.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-pin-utils
(package
(name "rust-pin-utils")