summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-21 13:09:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-21 13:09:56 -0400
commit1a1369dc3d0ba3e23f1f23581a0d1aac89e0db48 (patch)
treef8f6aee127ad2afec4270da1190758fced50c962
parent0a93e8ce328c2dc43eaeddd1033ef67d456bc4df (diff)
gnu: Add emacs-qml-mode.
* gnu/packages/emacs-xyz.scm (emacs-qml-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 10619efef0..5b68eb548c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7105,6 +7105,29 @@ asynchronously, with Counsel and Ivy. Simply call
commands and replacements for existing functions.")
(license license:gpl3+)))
+(define-public emacs-qml-mode
+ (package
+ (name "emacs-qml-mode")
+ (version "0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coldnew/qml-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sncsvzjfgmhp4m8w5jd4y51k24n2jfpgvrkd64wlhhzbj3wb947"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/coldnew/qml-mode/")
+ (synopsis "Qt Modeling Language (QML) mode for Emacs")
+ (description "This package provides the @code{qml-mode} major Emacs mode
+for editing source files written in the Qt Modeling Language (QML) user
+interface markup language. It provides syntax highlighting and basic
+navigation commands. @code{qml-mode} is derived from code{js-mode}, the Emacs
+builtin JavaScript mode.")
+ (license license:gpl2+)))
+
(define-public emacs-queue
(package
(name "emacs-queue")